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1. Importing Photos

There are several ways to do this:

1. Select Add Photos... command from the Workflow menu 

2. Click Add Photos toolbar button on the Workspace pane

3. Right click the chunk, go to the Add option, select Add 
Photos…

4. Drag and drop selected images directly into the chunk

Once you have selected Add Photos… (options 1-3), a dialogue 
box will open, find your photos and select the photos that you 
wish to process



1a. Importing Photos: Refining 
Selection

• Check through images for motion blur or 
unwanted photos

• Remove unwanted images 
Right click the selected image(s) and select 'remove 
cameras’, or click the remove camera icon in the 
photos pane

• Alternatively, disable the image
Click the disable cameras icon in the photos pane or 
right click the photo and select the ‘disable cameras’ 
option
Disabled photos are indicated by a red circle next to 
the thumbnail



1a. Importing Photos: 
Refining Selection

Image quality assessment

The image quality assessment tool in 
Agisoft looks for sharpness in an image 
relative to other images in the dataset

1. Switch to the detailed view in the 
Photos pane by clicking the Change 
View icon in the photos icon bar

2. Select the photos to analyse (ctrl+a to 
select all)

3. Right click on the selected photo(s) 
and select ‘Estimate Image Quality’ 
option

4. Once the analysis is done, a number 
indicating estimated image quality 
value will be displayed in the Quality 
column on the Photos pane. Sort 
lowest to highest and click through 
the low scoring images choosing 
which to disable and which to keep

Note that this assessment isn’t perfect, 
especially where the subject of the 
photograph has a surface that makes it 
difficult for the software to identify 
‘sharpness’



2. Import Masks: 
Agisoft Auto Creation 
(Background)

• You will need a photo of your background 
without the object present OR a black jpg file 
with the same resolution as your photos. Name 
this file background.jpg

• Select all the photos, right click, go to the masks 
option and select import masks

• The ‘Import Masks’ dialogue will pop up, enter 
the following parameters:

o Method: From Background

o Operation: Replacement

o Filename Template: background.jpg

o Tolerance: This will depend on the contrast 
between your object and background. If your 
masks cut into your object, raise the tolerance. 
If your masks include too much background, 
drop the tolerance. A good starting point is 50

o Apply to: All cameras or Selected Cameras



2. Import Masks: 
Manual Masking

Manual Masks in Agisoft

• Create 3-4 masks by hand, leave the 
other photos unmasked

• Once you have masked 3-4 photos 
(ideally, they should show different 
sides of the object), run the 
alignment with the following 
parameter:

o Apply Masks To: Tie Points

• This means that certain tie points are 
excluded from the alignment 
procedure. So, if an area is masked at 
least on a single photo, key points in 
other photos picturing the same area 
will also be excluded during 
alignment



2. Import Masks: 
Masks from Model

Masks from Model

• Align your model without masks and 
clean up the sparse cloud (following 
instructions in the Optimisation 
section of this guide)

• Build your mesh using the ‘from 
sparse cloud’ option

• Select all the photos, right click, go 
to the masks option and select 
‘Import Masks’

• The ‘Import Masks’ dialogue will 
pop up, enter the following 
parameters:

o Method: From Model
o Operation: Replacement
o Apply to: All cameras or Selected 

Cameras



2a. Masking: 
Refine Masks

Manual Masks in Agisoft

• Double click on a photo in the photos pane 
to view full size in the model pane

• Use the selection tool to create/edit a mask

• There are different types of selection tool

• The magic wand selection tool will select 
areas of similarly coloured pixels

• Once you have selected an area that you 
wish to mask out, right click on that area 
and select ‘Add Selection’

• This will add the selected area to the mask

• If you accidentally mask out some of the 
subject, choose ‘Subtract Selection’ instead 
of add (or ctrl+z to undo)



2b. Masking: Refine 
Masks
Important Note

• Masks sometimes have an influence on later 
model building stages and cause complications in 
depth maps generation

• Normally, this is not an issue, but if you are 
having issues with your depth maps and mesh, 
try resetting your masks after the alignment 
before running these stages



3a. Alignment: 
Running the Process
• Go to the Workflow menu, select the Align Photos 

option

• The ‘Align Photos’ dialogue will pop up, enter the 
following parameters:

• Accuracy: Lowest/Low/Medium/High/Highest
o Higher accuracies will take longer to 

process
• Generic Preselection: Selected
• Reference Preselection: Unselected
• Reset Current Alignment: Unselected

o Or selected if you wish to re-run an 
alignment

• Key Point Limit: 120,000
• Tie Point Limit: 80,000

o If your alignment is taking too long, 
reduce these numbers (e.g. to 40,000 
and 10,000)

• Apply Masks To: Key Points
o Unless using Manual Masking Method, 

then select Tie Points
• Exclude Stationary Tie Points: Selected
• Guided Image Matching: Unselected
• Adaptive Camera Model Fitting: Selected



3b. Alignment: Cleaning 
the Sparse Point Cloud
1. Duplicate your chunk as a backup

2. Go to the Model menu and select Gradual 
Selection

• Model > Gradual Selection

3. Reconstruction Uncertainty – Level 50

• Select OK and delete the selected 
points (in pink)

• Optimise Cameras (See slide 15)

Sparse point cloud cleaning is a very 
subjective process and often isn’t necessary



3b. Alignment: Cleaning 
the Sparse Point Cloud
• Make sure that you don’t delete too many points

o You will see the number of points being 
selected in the bottom left of the model pane 

o Try to keep at least 50% of the points that 
you started with

• If you deleted a lot of points you might get a 
“Some cameras have insufficient number of 
projections and will be reset. Continue?” If you get 
this popup, click “yes” and the program will try to 
reset the photos based on the remaining points.

• If you find that you have ‘over-cleaned’ your 
sparse cloud, go to your back up chunk (you 
should have duplicated the initial chunk before 
this process) and only use one of the gradual 
selection criteria



3c. Alignment: 
Optimise Cameras

Camera optimisation uses the existing tie 
points (which have been refined using the 
Gradual Selection criteria) to refine the 
camera orientations and triangulated tie 
point positions.

1. Go to the tool menu and click on 
‘Optimise Cameras…’

• Tools > Optimise Cameras

2. In the optimise cameras dialogue box, 
select ‘Adaptive Camera Model 
Fitting’

• This automatically selects the 
relevant camera parameters for 
us

3. Select OK, the optimisation will begin



3d. Alignment: Bounding Box

Only the area inside the bounding box will be 
processed. We must check and, if necessary, adjust 
the bounding box before continuing with the 
processing

1. To view the bounding box, go to the menu Model 
> Show/Hide Items > Show Region

2. Rotate your sparse point cloud, ensure that all 
areas you wish to process are inside the box

3. If the box needs adjusting, use the Resize Region, 
Move Region and Rotate Region toolbar buttons.



4a. Dense Point Cloud 
(Optional): Running the 
Process
• Go to the Workflow menu, select the Build Dense Cloud 

option

• The ‘Build Dense Cloud’ dialogue will pop up, enter the 
following parameters:

• Quality: Lowest/Low/Medium/High/Ultra High

o Higher qualities will take longer to run

• Depth Filtering: Aggressive/Moderate/Mild

o Aggressive for subject with little delicate 
detail, Mild for subjects with fine detail

• Reuse Depth Maps: Unselected

o Select if you are re-running the dense cloud 
and wish to reuse the same depth maps

• Calculate Point Colours: Selected

• Calculate Point Confidence: Selected



4b. Dense Point Cloud (Optional): 
Clean/edit dense point cloud

Manual Point Selection

• Go to the selection tool in the icon bar, you 
will be able to choose between rectangle, 
circle, and free-form selection

• Select points manually by clicking and 
dragging the selection tool, selected points 
will be highlighted in pink

• Delete the selected points, but remember, the 
selection tool ‘sees through’ the points and 
will select all the points in line with the 
selection area



4b. Dense Point Cloud (Optional): 
Clean/edit dense point cloud

Automatic Selection

• Agisoft offers different methods of automatically 
selecting points

• Tools > Dense Cloud > Select Points by Colour… 
you can select points of a specific colour and 
choose the tolerance for this (i.e. only choose 
points of that specific colour or select all similar 
points)

• Tools > Dense Cloud > Select Points by Masks… 
Agisoft will select all points which exist outside 
of the chosen masks, more suitable for when you 
have a few very precise masks



5a. Mesh: Running the 
process
Go to the Workflow menu, select the Build Mesh 
option

The ‘Build Mesh’ dialogue will pop up, enter the 
following parameters:

• Source Data: Depth Maps
o If you built a dense cloud, choose dense cloud 

here

• Surface Type: Arbitrary (3D)

• Quality: High

• Face Count: High or Custom Number (e.g. 5mil)

• Interpolation: Enabled (default)

• Depth Filtering: Aggressive/Moderate/Mild

• Calculate Vertex Colours: Selected

• Use Strict Volumetric Masks: Unselected



5b. Mesh: Cleaning

• Sometimes parts of the background or scale 
bar will reconstruct, you will need to delete 
these ‘floaters’

• You can either delete parts of the mesh using 
the manual selection tool (see 4b. Dense Cloud 
Clean Up for guidance)

• Or you can use the Gradual Selection tool 
o Model > Gradual Selection

• The gradual selection tool will offer two 
options, ‘connected component size’ and 
‘polygon size’

• The ‘connected component size’ will select 
floating fragments of mesh on a sliding scale 
based on size. If you choose a level of 99, 
everything except the biggest mesh will be 
selected. If you are happy with the selection, 
select ok and delete the selected mesh



Mesh: Cleaning

• Sometimes, meshes will have artefacts attached to the model, 
as a result, they can be difficult to delete

• The connected component size tool cannot be used as it only 
selects floaters

• The gradual selection polygon size tool can help in this 
instance
o Model > Gradual Selection > Polygon Size

• Polygon size selects polygons on a sliding scale, beginning with 
the largest polygons and increasing to the smallest

• This can be useful as artefacts tend to be made up of very 
large polygons



5b. Mesh: Cleaning 
(Smoothing)

• Go to Tools > Mesh > Smooth Mesh…

• Note that you can smooth specific areas of a mesh. Select your desired area with the 
selection tool in the icon bar. In the smooth mesh dialogue box, select the ‘Apply to 
selected faces’ option

• You can choose the strength of your smoothing , start low (e.g. 5) and work up. 
Remember to keep a duplicate, unedited chunk in case you over-smooth



5c. Mesh: Decimation

• Go to the Tools menu, go down to 
the Mesh option and select 
‘Decimate Mesh…’
o Tools > Mesh > Decimate 

Mesh…

• The decimate mesh dialogue box 
will pop up, input your desired 
mesh size
o We prefer 64k for uploading 

online

• You will be asked if you wish to 
replace your default model, select 
no if you want to keep your original 
mesh



6a. Texture: Refine Images

Refining Images

• If you haven’t done this already, run the Image Quality 
Assessment (see slide ‘Importing Photos: Refining Selection’ 
for guidance on how to do this). Remove any images which 
have motion blur/camera shake

• If you do not do this, your texture will be less sharp and will 
likely have blurred patches

• Note: if lighting conditions were inconsistent throughout the 
photography, you may want to run Colour Calibration (see 
page 38 of the Agisoft manual)

Masks

• You can edit masks by hand to exclude all out of focus areas

• Or you can use our advanced depth mask method, consult the 
online guide (forthcoming) for more information



6a. Texture: 
Refine Images

Ghosting: Creating and Combining Masks

• To avoid colour artefacts on your texture from background or support 
materials (aka ghosting), create a quick mask in paint (see image 3) where 
the black portion of the image will be masked out

• Combine this mask by selecting the photographs where the support is 
visible, and import the mask using the ‘Import from Background’ method 
and the  ‘Union’ operation

Original Image Photoshop Subject Select Mask Paint Created Mask Union of Masks



6b. Texture: Running 
the Process

• Texture Type: Diffuse Map

• Source Data: Images

• Mapping Mode: Generic

• Blending Mode: Mosaic or Average

• Texture Size/Count: 8192 x 1

• Hole Filling Enabled: Selected

• Ghosting Filter: Unselected 
o Unless there are thin structures or 

moving objects in your images, then 
select this option



7. Export

• File > Export Model

o In the dialogue box, name 
your file and choose the file 
type for export. We export as 
.obj

o Export as an .obj will produce 
three files, an .obj file, an .mtl
file, and a .jpg file

• Note that Metashape allows for 
direct uploading of models to 
Sketchfab. To do this, go to the File 
menu and select Upload Data…
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