Disease Model Cradle (DMC) practical
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Introduction

The “Disease Model Cradle” (or DMC) is an application which provides an interactive front-end to run a variety of
disease models (including LMM and the Rift Valley Fever model when available). Disease models encapsulated as
dynamic libraries are plugged into the application using a standardised interface, and the run results displayed
graphically. The aim of this multi-platform tool is to allow end-users to run models in their local institutions with their
own meteorological datasets and to investigate and validate the results with respect to epidemiological field
measurements (e.g. malaria incidences, number of infected mosquitoes for the LMM).

DMC is available for different platforms (Windows, Mac OS X, etc). In this practical we will mainly focus on using the
Liverpool Malaria Model (LMM) within DMC on the Windows platform.

The LMM (Hoshen and Morse, 2004) is a dynamic malaria model consisting of two coupled climate-driven
components, a disease transmission model and a mosquito population model. The transmission of the parasite
between human and mosquito hosts incorporates temperature-dependency in both the rate of development of the
parasite within the mosquito (the sporogonic cycle) and the mosquito biting rate (the gonotrophic cycle). The
mosquito population model incorporates both temperature and rainfall-dependency, with the availability of mosquito
breeding sites and larval mosquito mortality rate both dependent on decadal (10 day) accumulations of rainfall, and
the adult mosquito survival probability dependent on temperature (a number of published survival schemes are
available via DMC). A 2011 study (Ermert et al., 2011a, 2011b) extended the original model as developed by Hoshen
and Morse and carried out detailed calibration and validation of the extended model to derive a recommended
parameter set for West Africa. Both the original and 2010 parameter settings of the LMM can be obtained via DMC.
LMM has been used for both seasonal epidemic forecasting (Jones and Morse, 2010) and climate change (Ermert et al.
2011c) applications. See Appendix A for recommended parameter settings, definitions of the model output variables

and diagrams of the model structure.

Please note that the LMIM is a model, so results might be different from reality!

Installation

Windows version: Run the executable file called “DMC_vX.Y.exe” (where X & Y are version numbers, e.g.
DMC_v1.0.exe). Double-click on the file and click ‘Next’ until the installation is successful. All program files are stored
under the default windows directory “C:\Program Files\DMC” if this is not modified during the installation. Click on
the ‘Start’ button (bottom left of screen) and run the DMC entry. Tip: If you had a previous version of DMC installed on
your system, after the new installation uninstall using the program “C:\Program Files\DMC\unins000.exe” and then
redo the installation to resolve conflicts in registry entries created by the old (beta) version.

Mac OS X version: Mount the disk image file “DMC_vX.Y.dmg” (where X & Y are version numbers, e.g.
DMC_v1.0.dmg). Double-click on the image to show the contents in a folder and follow the instructions in the
“INSTALL.txt” file.



The data for this practical is in the folder “Senegal_example”. Copy this folder onto your system (e.g. the desktop).
Please note the location of the folder — we will call the location <your_location> in this practical. So the example files
will be located in the folder “<your_location>\Senegal_example” (using Windows notation).

|First steps with DMC

To begin select the DMC entry in the Start menu (Windows) or in the Applications folder (Mac OS X). Or double-click
on “C:\Program Files\DMC\DMC.exe” for the Windows version.

The DMC graphical interface looks like this:
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Like all software there are different ways to access the different functionalities of DMC:
The menu bar (red box): File, View, Tools, Models, on the top
The tool icon bar (blue box): Save, Averaging, Animation, etc icons just below the menu bar

The tool box (green box): Start date and averaging, Calculator... on the left hand side, can be pinned on the right hand
side by clicking on Dock control (green ‘right’ arrow), or can be detached (closed) from the main window by using the
double-window icon (cross icon) on the top right corner of the tool box. If you lose the toolbox you can just click on
the screw driver icon in the tool icon bar to make it reappear.

The graphical board (black box): where all inputs and outputs of the model used within DMC are displayed (map and
charts). The former example shows empty plots for the typical inputs and outputs of the Liverpool Malaria Model
(LMM).

To start you can just move and hover your mouse pointer for few seconds over the different icons in the icon bar and
elements of the toolbox. The functionalities are briefly detailed as a text tip. Note that DMC also supports a French
translation of the user interface (we will detail this point later) if you're not familiar with English.



DMC project and functionalities: Input data

Import input data:
For the LMM, the required input datasets are daily rainfall (in mm) and daily temperature (in °C).
In the menu bar, click on File->Import->Rainfall

A dialog box appears, then open the rainfall text file called “rain_Senegal.txt” in the folder
“<your_location>\Senegal_example”.

In the menu bar, Click on File->Import->Temperature

Again, a dialog box appears, then open the temperature text file called “temp_Senegal.txt” from the same folder
“<your_location>\Senegal_example”.

On the left hand side of the graphical board, the inputs should be shown as a gridded contour map and two
histograms.

Input data format:
Open the file “temp_Senegal.txt” with a text editor (e.g. Notepad or TextEdit).

The input dataset must be in ASCII (text format) and must be ordered like:

Latitudel (°) Longitudel (°) ntime (days) 13.875 -16.125 4748

Value day 1 (i.e. value for 1% Jan 1998) 29 ’ 829 ) '

Value day 2 (i.e. value for 2" Jan 1998) :
21.918 4748 daily temperature
24.487 > values for Node1
27.103

. . J

Value day Ntime (i.e. value for 31 Dec 2010) 13.875 -15.875 4748

Latitudel (°) Longitude2 (°) ntime (days) 22.830 N

Value day 1 (i.e. value for 1° Jan 1998) 29 342 4748 daily temperature

Value day 2 (i.e. value for 2™ Jan 1998) 24.767 \ values for Node2
27.185

J

For this example we have used ERAINTERIM temperature gridded data and TRMM rainfall gridded data at 0.25°x0.25°
resolution covering the period 1998-2010 (4748 days) over a domain covering Senegal (lat = 10.5°N-17°N, lon = -18°E -
-11°E or 18°W-11°W). The longitude convention is based on a centered Greenwich System (from 180°W to 180°E,
negative for western longitudes).

Using this format you can import gridded or station datasets. We define a ‘node’ as a geographical point (e.g. a grid
node or a station position). All data can be in one single file (like the former example, where all nodes are
concatenated in the same text file) or in separate files (one file per node, keeping the spatial latitude / longitude
reference and the number of time steps on the first line of each file, which is easier for station dataset). If you have
one file per node, you can import multiple files simultaneously into DMC by selecting all the files in the Import File
box. All nodes should have the same common reference time period and no missing data values are allowed.



|DMC project and functionalities: Start date |

Scale the time period shortcut CTRL+SHIFT+D
NOTE: DMC DOES NOT AUTOMATICALLY KNOW THE START TIME OF YOUR IMPORTED DATA.

The first thing to do is to enter the start time of your dataset. For this Click on the start date and averaging icon (&l in
the toolbox or the tool icon bar or the menu Tools->Start Date and averaging)

[ Start date & averaging In the Start box, you can manually modify the start date or

Start 27/06/1 =

| Climate averaging \
Season [JEM Use the Choose date calendar icon on the right of this box.

4

Apply <\
Click on Apply changes

For this example set the start date to 01/01/1998 (which is the start date of the rainfall and temperature dataset for
Senegal). Do not forget to apply you changes by clicking on the Apply changes «£

The histograms should now show realistic rainfall and temperature seasonal profiles for Senegal. The rainy season
occurs between June and November and the warmest season in March-April-May. Note that the current version of
DMC only works for the standard Gregorian/Julian calendar (365 days with leap years).

DMC project and functionalities: Open, save a project and preferences

1
Save DMC file: H shortcut CTRL+SHIFT+S

In the menu file: File->Save (or File->Save As). A dialog box will open, you can now save your project as a *.dmc file.
Name it “Senegal_examplel” and save it to your desktop. You can also use the Save button in the icon bar to save

your project. Then quit DMC.
Open DMC file: shortcut CTRL+O

Restart DMC and in the menu: File->Open then select the file you just saved on your Desktop
“Senegal_examplel.dmc” (or just simply double-click on the file as you would do for a Word document). All
modifications you made above have been taken into account; you can now continue to work on your DMC project

document.



Preferences:
In the menu bar click File->Preferences, the Preferences dialog box will appear with the default settings:

Preferences =] / Write Model output to files: Allow saving the daily model outputs (here the

Files

LMM, so outputs such as “Daily malaria incidence”...) in text files to allow the
|¥| Write model output to ﬁles

7] Always ask for output folder user to do further analysis on the output data (more details later in the section
e e about running the LMM with DMC). Enabled by default.

Parallel processing

/'

Always ask for output folder: The DMC software will ask you for the directory

[¥] Use parallel threads for modelling
Map animation where you want to store the model outputs every time the model is run.

Speed & D

Plot Fonts Write Model output to document: Check this box if you want to save the model

Title output (in this example from the LMM) to your *.dmc project file.
Axes
Labels
Use parallel threads for modeling: Activate parallel processing, this is enabled

by default (modeling is faster if your computer has multiple cores).

oS PR e Map animation speed: define the speed of the animation (see later on in the
A practical)

Plot fonts: Allow changing the font of the title, axes and labels on the plots.

Model Plugin folder: Define the location of the disease models you can select
within DMC. Do not modify if you’re not an advanced user.

Language: Choose English or French as the user interface language.

You can restore all modifications to the Preferences by pressing the “Reset to
Defaults” button.

Initially uncheck the box “Write model output to files” as we do not want to save any model outputs at the moment.

DMC project and functionalities: Play and interact with the graphics

The DMC graphics are all interactive!

To start you can click on the rainfall histogram on the bar for the month of August. The map changes to show rainfall
patterns for the month of August as well. Do the same on the temperature histogram on the bar for the month of
March, the map now shows mean temperatures for the month of March.

The map is also interactive. First click on the rainfall histogram bar to display rainfall on the map. Then click on a node
in the map: the time series (histograms) shown below the map are now those corresponding to this specific node. A
cross appears in the node that is selected on the map and the corresponding lat/lon coordinates are written in the
title of the displayed histograms.

Example: Click on the rainfall map on the lower left corner node (10.5°N, -18°E). You can see that the rainfall season
ranges from June to November with relatively large rainfall amounts. Do the same on the top left corner node (10.5°N,
-18°E): the histogram changes and depicts a shorter rainy season lasting from July to October (Sahelian profile).

Note that both input (rainfall and temperature in the LMM example) and output (e.g. malaria incidence, number of
infectious mosquitoes...) plots are interactive. Actually we are focusing on the model climatic inputs - we will talk later
about the model outputs.



Apply mask to the map: -

In the Menu Bar: Tools->Apply mask or in the icon bar click on the mask icon. This will popup a dialog box to open the
mask text file you want to apply to your data. Open the file “mask_Senegal.txt” which is located in
“<your_location>\Senegal_example”. All nodes that do not belong to Senegal have now been masked. The mask file
format is an ASCII text file and the format is consistent with other input file format:

Latitudel (°) Longitudel (°) 1 10.625 -17.875 1
One mask Value (0 hidden, 1 shown)

Latitudel (°) Longitude2 (°) 1 8
Mask Value (0 hidden, 1 shown) 10.625 -17.625 1
0
10.625 -17.375 1
. 0
Latitude_i (°) Longitude_j (°) 1 10.625 -17.125 JJ
Mask Value (0 hidden, 1 shown) 0

You can open the file “mask_Senegal.txt” with a text editor (Notepad, TextEdit, etc) to inspect the format. You do not
have to define an entry for every possible node in the mask file: you can just add specific entries with a ‘0’ to hide
certain nodes. Nodes that are not defined within the mask file are assumed to be visible.

Time manipulation: shortcut CTRL+SHIFT+D

In the tool box click on the “Start date and averaging” button, or in the tool box click on the calendar icon or in the
menu bar: Tools->Start Date and averaging.

Tools ®X  For the start date see previously

M Start date & averaginge—

Start 01/01/1998 ‘7 Climate averaging: the data shown are based on a mean seasonal cycle averaged for

' . the whole time period. Uncheck the box if you want to display seasonal means.
v| Climate averaging

Season | JFN
0 . W season (need to uncheck Climate averaging to activate) or
"\4\\6dit,create or delete a season

and then apply changes

N.B. We already fixed the start date of the climatic data we are using to 01/01/1998.

We are now going to play with the different time functionalities. By default the data are displayed for “climate
averaging”. This means that the mean seasonal cycle of the input and output data is computed for the whole time
period (1998-2010 in this example).

You can uncheck the box “climate averaging” and select a standard season that might interest you. JFM stands for
January-February-March seasonal average, FMA for February-March-April seasonal average, etc.

Select JAS (July-August-September) by choosing from the season pulldown menu. Click on Apply «£. Now all graphics
depict annual values for this typical season. Click on a node on the rainfall map over northern Senegal. The rainfall
histogram shows that large rainfall was experienced over this region in 2010, while 2002 was a relatively dry year. This
can be used to explore specific years.

You can edit [4, create a new season [l and delete [€] seasons.



Let’s start by defining a new long rainy season called “MJJASO” (May to October) which fits the rainfall mean seasonal
cycle over Senegal. To do this, click on the green plus icon [ and define the season name as “MJJASO”, then for the
start you can use the calendar icon on the right Z1, or manually edit it in the text box, and fix the start date to 1% May.
Do the same thing for the end by setting it to 31* October and click “OK”. Do not forget to click on Apply changes «£
once you have finished. Once defined, the season MJJASO will now appear in the season pulldown menu. You can use
the orange minus icon €] to delete it later if you wish.

Season @

Name MJJASO
Start 1 May 3™
End 31 October ™

You can also create a season called “Annual” by setting the start to 1* January and the end to 31" December. Do not
forget to apply changes. Now annual averages are depicted for all inputs and all outputs on the time series and for the
map. In summary DMC allows you to visualize mean seasonal cycles averaged for the whole time period, the seasonal
average and annual averages for any given year.

Calculator: |:| shortcut CTRL+SHIFT+E

In the tool box click on the “Calculator” tab, or in the tool bar click on the green calculator icon or in the menu bar:

Tools->Climate data calculator.

Select the Input you want to modify

Calculator
Data |Rainfall Select an operator (here multiply)
Operator |* (multiply) Enter the operand (here multiply by 10)

Operand 10 4/

4—/Un‘d"/ Then apply changes (you can still undo the changes if you make a mistake)
Apply 0  gq—

This tool allows you to modify, for instance, the units of the input datasets (for this example rainfall and temperature)
by applying different operators (+ - * /) and operands. The LMM expects daily rainfall in mm and daily temperature in
°C as inputs. The data you are actually using in this example already have the proper units. But if you started with
rainfall in meters and temperature in degrees Kelvin, you may multiply (*) rainfall by 1000 to get mm or subtract (-)
273.15 to transform degrees Kelvin to degrees Celsius.

As an example choose Rainfall in the Data pulldown menu of the Calculator. Use the Operator “multiply” then set the
operand to 10 (so multiply input rainfall by 10). Click on Apply changes «£. The values on the time series and the map
have been multiplied and rescaled. As we already have proper units in our data, press the undo button 0 to restore
the original values.



Show/hide Plots: k& shortcut CTRL+SHIFT+H

In the tool box click on Show/hide plots button or the flag icon in the icon bars or in the menu: Tools-> Show/hide
plots.

* Show/hide plots
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If you uncheck/check the boxes associated with variable time series they will be hidden/shown in the graphical board.
Uncheck the rainfall, and note that the rainfall time series histogram has been hidden, and then recheck it to make the
plot reappear. This control also governs which time series histograms will be output with the File->Print... command.

Fa
Map markers properties: !._) shortcut CTRL+SHIFT+M

In the tool box click on the Map tab or the earth icon in the icon bar or in the menu: Tools->Edit Map markers. This
tool allows you to interact with the map shown in the graphical board.
@ vap Outline markers: add an outline to each node marker.

V| Outline markers

7| Layoutmarkersinarid  d——

Layout markers in grid: Constrain spacing of the markers on the map to make it
look more like a grid.

Symbol: Change the type of symbol (square by default, triangle, circle...)

Vary size with value: Change the marker size as a function of the related
input/output value, and then use the size slider to apply the factor.

Tick the box “Layout markers in grid”. Now the map looks more like a gridded raster. Note that you can experiment
with the aspect ratio on the plots. In between each window pane (there are three panes — the map, the input plots
and the output plots), move your mouse pointer slowly. A double arrow will appear. Left click and drag to modify the
aspect ratio of the map plot until you find something you like. Now uncheck “Layout markers in grid” and check the
“Vary with size with value” box. Change the symbol to circle then play with the size slider to visualize rainfall value for
the month of June (first you need to reapply “climate averaging” in the “Start Date and averaging” tool box). You can
quickly see that the largest rainfall occurs over southern and especially, southwestern Senegal in June. You can then
experiment with the different marker settings.

Once finished, reset the symbol to square and recheck the box “Layout markers in grid”. You can also show the
numeric values on the map, for this use the Show/hide map marker value icon & or in the menu: View->Show map
values. Now move your mouse over the map, values will appear near the mouse pointer. Click % again to disable this
function.



Map animation: @ shortcut CTRL+SHIFT+A

Click on the animation icon in the icon bar or in the menu: Tools->Map animation. This allows you to animate the map
for any time series variable shown in the graphical board. You can change the animation speed in the Preferences (see
Preferences section).

Map Animation g @

» | Dec ‘G [T

Press Play (pause) to start (pause) the animation. If you check the box on the right, the animation will loop.

Color palette: m shortcut CTRL+SHIFT+C

In the tool box click on the Colour palette tab or the colored disk icon in the icon bar or in the menu: Tools->Edit
colour bar. This allows you to edit, create and delete color palettes for the map.

9 Colour palette Value display: Display all plot values (for both the map and the histograms) as
Value display relative (min and max on the plots vary as a function of the time step) or
® Absolute @ Relative absolute values (min and max are fixed to the same value for all time steps).

Variable Rainfall

Variable: the current time series variable you have selected.
Palete Y
400 Palette: Two palettes are defined by default, one ranging from white to blue,

applied to rainfall and one from white to red for temperature.

You can then choose, edit 4, create [, or delete [& a color palette for each
variable. The palettes are saved in the *.dmc project file.

Example: Click on the green plus button [ and create a new palette called “Greens”.

- COIour palette @ # . Select color - - — _ &J
Basic colors
NN
I ‘ J
I ]
" Name Greeng| EEEEEEE '
o I
| Minimum colour |2 e
Maximum colour ;
<|3_”|5‘|T %Olrs_ll_ll_ll—i_l Hue: 240 =l Red: 160 2
Sat: 6 7| Green: 160 ©
OK [ Cancel ] I o o o — e
’ l [ Add to Custom Colors ] L hiado e Ll
Click on a colour button “...” to open the colour selection dialog. As a minimum value select white, then “OK”, and for

the maximum pickup a dark green (using Basic colors or the color matrix on the right). Once you have finished click
“OK”. The new color palette is now available in the palette box and you can use it to depict rainfall in the map (for
example). Basic HSV / RGB palettes can be edited. The colour selection tools look different on different operating
systems — here we show the Windows tools.



Time series: 2“_ shortcut CTRL+SHIFT+T

In the tool box click on the Time series tab or the Time series icon in the icon bar or in the menu: Tools->Edit time
series style. This allows you to modify the time series style (height, filled color, etc).

Time series / You can change the fill color of the histograms (works like defining a color palette)

Fill colour
and change the height of all time series in the graphical board.
Minimum height 200 A/ 9 9 f grap

As an example, change the time series fill color with the color you like the most and then set the minimum height
value to 100. Once you tested this please reset the minimum height value to 200.

Print plots: i.e. export graphic images: shortcut CTRL+P

In the menu: File->Print.... This allows you to export the graphics displayed in the graphical board as images (use the
Show/Hide toolbox to select a subset of the plots if you don’t want to export all of them). Different formats are
available (*.jpg, *.png, *.gif, *.tiff, *.bmp, *.ppm, *.xpm, *.pdf, *.ps, *.svg). This will allow you to import DMC images
for further use in other documents (e.g. Word, PowerPoint...).

& print.. L2 | Format: Select the output image format (*.png, *.pdf, etc).

Select the format and resolution, and the folder in whigh45
the printed files. All the plots currently shown op#f€ screen will
be printed.

Resolution: Change the output images resolution in dots per inches (dpi)

Format:

Resobton@): 20 = | Change output folder: Define the folder where the images will be saved to.

Folder: C:/Users/caminade /Desktop/tmp A/—
Change output folder...

Then press the Print button to export the graphics as images.

[ Cancel l [ Print ] ‘/ T

Running the LMM with DMC

Now that you are familiar with the functionality of DMC it is time to use it to run a disease model: the Liverpool
Malaria Model.

Remember that DMC is just an interface into which can be plugged different disease (or other) models driven by
various inputs. The current version of DMC actually comes with the LMM, and other models will be incorporated later
(Rift Valley Fever, Dengue, etc). So now we are going to run our first LMM simulation with DMC.

In the menu, click on Model, you can see that LMM is the model used in DMC by default; later on other models will be
available and will be selected here.

To run the model: Ll shortcut CTRL+R

In the menu, click on Model->Run... or click on the histogram icon i in the tool icon bar.

& omc 2 [

|

Modelling...
|
15%

Interrupt

o -_—

You can then see the progress bar of your malaria simulation. You can press the Interrupt button at any time to stop

the modeling process.



Once this is finished you should see the model outputs displayed on the right-hand side of the graphical board.

Click on the “Malaria incidence” time series, the map should display the malaria incidence pattern for Senegal. Using
the tools we described above, display “Climate averaging” (using “Start date and averaging”), setup the color palette
to Blues (in “Colour palette”) and the click on the (& icon to create an animation. You can clearly see that the
SIMULATED malaria season over Senegal is relatively short and ranges from September to November.

Now select the malaria season “SON” (in “Start Date and averaging”), do not forget to apply «£ changes. Now the
values are shown for each year for the seasonal average Sept-Oct-Nov. This corresponds to the simulated malaria
season length you previously identified using the animation or by inspecting the malaria histograms on the right.

Click on a node located near 15N-15W on the map. You can see that the highest simulated malaria year is 2010, for
which high rainfall was observed. Continue exploring the data. Look at differences between northern and southern
Senegal...

Go to Preferences and check the box “Write model output to document”. Save your document as
“Senegal_LMM_standardsettings”. You will be able to reopen the file later and your LMM simulation outputs will be
restored. Note that the dmc file is now larger and uses more disk space.

i,

Model parameter settings: LGJ shortcut CTRL+SHIFT+P

Click on the cog icon in the icon bar or in the menu: Tools->Model parameters. This allows you to modify the model
parameter settings you are using (here for LMM) before running your simulation. A parameter controls dialog box will
appear.

Parameter Control - L All controls: Allow user to modify all parameters (for
= advanced users).
Human inoculation effidency (floating point)
e = u Reset Defaults: use the standard LMM parameter
Human Blood Index (HBI) (floating point) i
e os 0 settings.
Human Recovery Rate (floating point) \
wie [ 0.0 0 -\ Show/Hide: choose which parameters are displayed.
GamInfProb (Mosquito inoculation efficency) (floating point)
Value 1 {
Rainmult (floating point)
Vale 1 This is the list of parameters that can be modified:
MosquitoCap (floating point)
Vaue w0 ] Example: The Human inoculation efficiency (default
Tg Low Humidity (ﬁoahrlg point) va lue 0. 5)
Value 45 [}
Dg Low Humidity (floating point)
Value 65.4 [}
Ta High Humidity (floating point)
value 77 [
Dg High Humidity (foating point) _/

At this stage you can change the different parameter values to those which seem more appropriate for your study
area. When a parameter value is modified from its default value it is displayed in red. For more details about the
different parameters see the associated LMM document.

As an example we are going to change the parameter settings according to recommendations and based on field data
that have been provided by the Institut Pasteur in Dakar.

More realistic “Human biting rate” values were simulated when the rain multiplier factor was set to 0.07 and for
“Adult mosquito survival” which fit the Craig-Martens survival scheme (Survival type = 3 in the parameter list).



Change the “Rainmult” factor to 0.07 (by typing it into the box or moving the slider). Check the “All Controls” to reveal
the advanced tools. Then change the “Survival type” scheme by clicking on the “Limits”, set the maximum to 3, then
“OK”. Then change the “Survival type” value to 3 (Craig Martens survival scheme instead of Martens scheme). Then
uncheck “All Controls”. The more advanced controls are intended for sensitivity tests, which can consume a lot of
resources, and should only be used by advanced users.

Close this window and rerun the model.

Save the new file as “Senegal_LMM_IPDsettings”. Explore the model outputs using the different functionalities of
DMC. Look at the number of infectious biting mosquitoes on the time series. Reopen the DMC document created
using standard settings i.e. “Senegal_LMM_standardsettings”. Comment on the differences and the similarities.

To finish, reopen the DMC document “Senegal_LMM _standardsettings”.
In Preferences check the “Write model output to files” box.

Rerun the LMM. Now DMC is asking you where you want to save the daily output of the LMM. Select or create a
directory using the dialog shown. The output may require a significant amount of space available on your hard drive.
Check that you have enough room before processing.

The values are outputted for each node in a specific folder named after the “node_number” (e.g. node000, node001,
etc). Inside there is a sub-folder called “0” in which each variable outputs are saved (for LMM daily values) in various
text files for all standard outputs of the model (Incidence, Prevalence, etc). Each “0” sub-folder contains a file called

“

_info.txt” that summerises all the parameter settings and location data for model run at that particular node.

These files can then be used to do further analysis on the daily outputs using Excel, Minitab, SPSS, etc.

Data used within this practical

The Senegal rainfall dataset is based on TRMM satellite rain gauge estimates (Huffman et al., 2007) and temperature
files are based on the ERAINTERIM reanalysis dataset (Dee et. al., 2011, Uppala, 2008). Temperature has been
interpolated to the TRMM native data grid.

Period: 1998:2010, daily resolution data
Spatial resolution 0.25x0.25 degrees covering the Senegal domain i.e. [10.5N-17N, 18W-11W]

Details:

Daily rainfall is derived from the Tropical Rainfall Measuring Mission (TRMM) dataset (3b42 version 6, 0.25° spatial
resolution). The TRMM product is a joint satellite project between NASA and JAXA designed to improve observations
of precipitation over the tropics (23). The mission incorporates several instruments, including a microwave imager,
radar and visible-infrared scanner. The final daily product is derived from a combination of TRMM data and other
satellite infrared observations (e.g. Meteosat, GMS, GOES and NOAA-12).

The user should cite and acknowledge these datasets when they use the related DMC examples; if there is any
publication related:

References:

Huffman, G.J., R.F. Adler, D.T. Bolvin, G. Gu, E.J. Nelkin, K.P. Bowman, E.F. Stocker, and D.B. Wolff. (2007): The TRMM
Multi-satellite Precipitation Analysis: Quasi-Global, Multi-Year, Combined-Sensor Precipitation Estimates at Fine Scale.
J. Hydrometeorol., 8: 38-55.



Uppala, S., D. Dee, S. Kobayashi, P. Berrisford, and A. Simmons (2008): Towards a climate data assimilation system:
Status update of ERA-Interim, in ECMWF Newsletter, 115:12fi18, European Centre for Medium-Range Weather
Forecasts, Reading-UK.

Dee et al.,, 2011: The ERA-Interim reanalysis: configuration and performance of the data assimilation system. Quat.
Jour. Roy. Met. Soc., 137:553:597.

More details about the ECMWF ERAINTERIM product at: http://www.ecmwf.int/research/era/do/get/index
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|Appendix A: The Liverpool Malaria Model

I A1 Suggested LMM parameter settings

a) Floating point parameters

Default . Definition/Notes
. Ermert (2011) Setting
Name Setting

DISEASE TRANSMISSION

. . o Probability of human infection given
Human inoculation efficiency 0.5 0.3 . . .
an infectious bite

0.8 (0.4 incorporating
Human Blood Index (HBI) 0.5 adult/child conversion Proportion of bites taken from humans
rate)

Proportion of human population which
Human Recovery Rate 0.0284 0.0050 return from infectious to susceptible,
per day

Proportion of humans with
GamFrac N/A 0.5 . )
gametocytes in their blood




GamInfProb (Mosquito 10 02 Probability of mosquito infection given
inoculation efficiency) ' ' an infectious bite
Rainfall multiplier relating number of
Rainmult 1.0 N/A eggs per female to dekadal rainfall in
mm
. Upper limit applied to number of
MosquitoCap 10000.0 400.0 ) .
female mosquitoes laying eggs.
LARVAL MOSQUITOES
Multiplicative factor used for rainfall
LarvalRateFactor 1.0 0.0 ) . .
term in computing larval survival rate.
Offset added to rainfall term in
LarvalRateOffset 0.0 0.825 . .
computing larval survival rate.
FuzzyEgg:
9:U1 0
Parameters governing fuzzy logic
10:S1 N/A 10 g . g yioe
process for egg laying.
11:U2 10
12:52 500"
FuzzylLarvae:
13:U1 0
Parameters governing fuzzy logic
14:51 N/A 10 & g' yioe
process for larval survival.
15:U2 10
16:S2 500
ADULT MOSQUITOES
When the Lindsay-Birley mosquito
Gonotrophic Cycle survival scheme is invoked, the
. N/A N/A . . -
Survival proportion of mosquitoes surviving
each gonotrophic cycle.
o Gonotrophic cycle threshold - low
Tg Low Humidity 4.5 4.5 s
humidity (°C)
o Gonotrophic cycle length - low
Dg Low Humidity 65.4 65.4 s
humidity (degree days)
Tg High Humidity 7.7 7.7

Gonotrophic cycle threshold - high

' Fuzzy parameter names are labelled here to be consistent with those used in the current version of the model but

actually they are not consistent with terminology usually used for fuzzy logic modelling (U1,51,52,U2).




humidity (°C)

Gonotrophic cycle threshold - high

Dg High Humidit 37.1 37.1
gnie Y humidity (°C)
Dekadal rainfall threshold (mm) for
Rt 10.0 10.0 . o
low/high humidity
Ts 18 16 Sporogonic cycle length (degree days)
Ds 111 111 Sporogonic cycle threshold (°C)
. . Fractional offset applied in Bayoh
BayohSurvivalShift N/A N/A )
survival scheme.
. . Parameter governing mosquito
DrySurvivalShift 0.0 -0.1 .
survival at the end of the season.
. Dekadal rainfall below which survival
RainSeasonThresh 0.0 10.0 . . .
shift parameter is applied.
. Trickle of infected mosquitoes added
MosTrickle 1.01 1.01
every 10 days
. Trickle of infected humans added
HumanTrickle 0.0 0.0
every 4 days
b) Integer parameters
Ermert et al

Name

Standard Setting

(2011) Setting

Definition/Notes

Survival type

Survival Scheme
0: Martens
1: Lindsay/Birley
2: Bayoh

3: Craig version of Martens

EggFunc

Functional form used for egg laying:
0: Linear
1: Logarithmic

2: Fuzzy Logic

LarvalScheme

Functional form used for larval survival

0: Original form (rainfall function tending to 1
for high rainfall, 0.5 for low rainfall)




1: Fuzzy logic function

MosMatureAge 15 12 Age in days at which larvae reach maturity

. Number of days after infection at which
HumanlinfectiousAge 15 20 . .
humans are infectious

I A2 Model output variables

The current LMM outputs are:
* Incidence (malaria cases per 100 people)
*  Prevalence (proportion of the human population infectious)
* Gonotrophic cycle length in days
* Sporogonic cycle length in days
*  Total number of adult mosquitoes
* Total number of infectious mosquitoes biting at a given timestep
*  Total number of larval mosquitoes

* Total number of mosquitoes biting at a given timestep.

I A3 Structure of the LMM

larval mortality adult mortality
My, u,M,
maturation gonotrophic
Larvae Adults cycle
M M
’ ‘ dG
dt
N e i
: ovipositioning !
dG
M —
M, dT

Figure A1 Mosquito population component of LMM. The population is divided into immature (larvae) and mature
(adult) categories, M, and M,. Larval mortality occurs at a rate y, and adult mortality at a rate u,. New larval stage
mosquitoes enter the population as eggs, with ovipositioning occuring at a rate dependent on the size of the adult

population M, together with rate of progression of the gonotrophic cycle d_G and the number of eggs laid per

dt
mosquito per cycle, B. The maturation rate from larvae to adults depends on the variable larval mortality p;
experienced during the larval stage and the fixed larval development period /.



Maturing

larvae
u(l-y, -»,)

Wy,

S
(I-y;2)

Mosquitoes

(A)

v

abmy,(1-x, - x,)exp(-rt,)

acx,(1-y, - y,) ‘ B
L dt
Vi
6\lcx2
abmy, :
abmyz(l_xl _x2) R
> L
X;
A\ 4 rx]

Y,

Humans

Figure A2 /llustration of malaria transmission component of LMM, showing susceptible (S), latent (L) and infectious (1)

classes for each population: mosquitoes (y) and humans (x).

Instantaneous rates of transfer between the classes can be expressed in terms of the model parameters and the

proportion of population in each class at time t or t-1, . The rate of transfer (A) from latent to infectious class for

mosquitoes cannot be expressed this way if the rate of progression through the sporogonic class is variable.

Maturing larvae enter the susceptible class of the mosquito population at a variable rate according to the mosquito

population model previously described. Rate of infection of each of the susceptible classes depends on the biting rate

a, population susceptibilities b and c, vector density m (for the infection of humans) and the magnitude of the

susceptible and infectious proportions of the relevant populations. The biting rate, a is variable, depending on the rate

of progression of the gonotrophic cycle. The vector density, m, is also variable since the mosquito population is not

fixed.



